Forums » CentiLeo for Cinema 4D
Pages: 1
How to access plugin once loaded?
User  Posts: 18
Feb 9, 2021 14:59
Hello, thank you for this software. I believe I have loaded the plugin correctly as per instructions, but I can only see CentiLeo mentioned as a Node Space option. Where am I supposed to access the functionality for CentiLeo exactly? I don't see any mention of it in render settings and I don't see any kind of dropdown menu. I am on C4D R23.008 Any advice?
Hi ds,
I think you'll need 23.110. You just need to update Cinema 4d to this version for it to work fine. I've been using it for a few weeks now and its really very good and it's also very fast.
Administrator  Posts: 774
Feb 9, 2021 15:42
Hi Ds! Welcome here! Ron is right, thanks, you should update to Cinema R23.110 or higher build version. It done using Cinema GUI automatically and for free. This update will also reduce the bugs of Cinema itself!
This is mentioned on the in a section titled "If CentiLeo doesn't show after installation".
User  Posts: 18
Feb 10, 2021 05:13
Thank you, I've gone ahead and updated to R23.110 and now it works!

I then did a test render of a scene to compare speeds. On i7 CPU, my render took 1 hour 17 minutes. Then I changed the cameras, lights, and materials to use versions provided by CentiLeo and re-rendered the scene with an RTX 3070. That render took over 7 hours!

I notice in the task manager under performance, I can see the GPU usage during the render. There are bars tracking utilization and I can see "3D" stays quite low (3-5%) while "Copy" stays at 100% except when it finishes rendering a frame and moves to the next. And only 4.5/8gb in GPU memory is being used. So all of this suggests to me there is I have a memory issue where any gains I might get from the faster computation on the GPU are negated by the time it takes to transfer data to the GPU.

So my question is, is there anything I can do to improve this situation? 62.1K triangles, 127 meshes, 11 materials, 2 lights.
Administrator  Posts: 774
Feb 10, 2021 05:55
Wow, this looks very wrong. Please, help me to investigate wha'ts going not the right way.
I would like to see the screenshots from IPR like here
At the botoom of IPR there is a bar "GPU Indicators". It's enabled with mouse right click and selecting "Show GPU info" in menu. To understand what's every number meaning see here

How many textures are there in the scene? And what's the interface of GPU connection to Motheboard? PCI-Express direct connection or through the riser? I don't think the out-of-core textures should behave like this. There were so many tests with far bigger scenes on smaller harware with great performance.
Another potential reason: what drivers have you installed? Latest ones? How many other GPU programs are working at the same time? Any Mining, Octane, Redshift for e.g.?
User  Posts: 18
Feb 10, 2021 05:58
Another test, I tried rendering a scene with a single sphere in the center and the physical renderer in C4D takes less than a second where CentiLeo takes 17 seconds.

Apologies if I am missing something obvious, I was very excited to use my new GPU to help with renders but now find myself learning quite a bit about GPU-based renderers, pretty interesting but also quite confusing.

[ just saw your post above when I clicked "post", I will gather that info and repost ]
Edited: ds - Feb 10, 2021 05:59
User  Posts: 18
Feb 10, 2021 06:15
Here is a screenshot of IPR with GPU info.

Only 1 texture on the screen at this point. GPU is connected directly to the motherboard via PCI-E x16. Not doing any other kind of GPU heavy activity during the render. The hard drive is NVMe. Drivers are 457.51 -- I will check if newer ones are available.
Administrator  Posts: 774
Feb 10, 2021 06:26
Yes, whatching videos, serfing web Chrome is ok while doing GPU render. They don't make problems in my practice.

The screenshot looks fine! The speed indicator "SPS" (samples per second) is ok.
You just need to reduce the amount of Render Max Iterations. It computes 32x64=2048 samples per pixel while it's ready at 1 iter (64 samples per pixel). You don't need default 32 iterations: see CentiLeo Render settings.
Can you please show the screenshot of the first scene (not a sphere) as an example of reasonable scene with 1 iteration?
User  Posts: 18
Feb 10, 2021 06:53
Updating the driver had no effect, but lowering the iterations from 32 to 1 seems to have increased the speed by a factor of 32 or so :D

Here is a screenshot:

Thanks, I will play with this a bit, it does look quite a bit faster! For some reason I thought 32 was kind of the "suggested" iteration amount so I didn't play with this param at all.

Looks like it's going to be 21 minutes on GPU vs 1 hour 17 minutes on CPU.
Administrator  Posts: 774
Feb 10, 2021 09:06
21 min looks too much anyway also for 1920x1080 at 1 iteration. It should be seconds! Really! I am not joking :)
Can you give me a full scene please for my tests? To I will probably also give you a debug version with some more detailed info.
User  Posts: 18
Feb 15, 2021 14:26
Naw, it's not as bad as it seems I think, that was an animation with 91 frames, so each frame was 13 seconds or something like that. I have been enjoying learning to use this renderer (while also learning C4D) and tweaking the various settings. I have a question regarding materials I will ask in a separate thread.
Administrator  Posts: 774
Feb 15, 2021 19:43
Hi Ds! Well... I was very nervous about this thread :) I also thought you are trolling me :) 21 minutes for 1 very simple scene on a very-very good GPU!
13 sec is ok and it will be less in the near future within several monts so stay tuned. Ask any questions you want, I love C4D and working on this integration with huge enthusiasm!
Pages: 1
Users browsing this topic