Forums » CentiLeo for Cinema 4D
Pages: 1
Centileo crash with strange pattern over image
Greetings! I have encountered some very strange crashes with CentiLeo. They happen on every second render with all Centileo's scenes. The computer starts, I open the c4d scene, press the render IPR CentiLeo, everything is fine. Then I close the IPR window and open it again and this strange pattern covers image. After closing the window, Cinema crashes. All further attempts lead to the same thing. Link to screen record video of this glitches -

The strange pattern covers the entire image, and it is also saved to pictures while task in render queue or production render. I tried other versions of CentiLeo, also tried in combinations with other versions of Cinema 4d, the result is the same. Only one clean render attempt after PC restart.

The first thing I thought was a problem with the GPU. But long tests show that GPU is fine. I tried other render engines (v-ray, redshift, cinebench..), some GPU stress tests, such as Furmark, some heavy games. Everything is fine.

Before that, I used CentiLeo for more than 8 months and only last week this terrible glitch appeared. Now I want to understand, is this a problem with the software, or this is the first call of upcoming GPU death?

GPU: RTX 2080, Win 11, GPU Driver 546.01

Screenshot_6.jpg (614.93 Kb)
Screenshot_4.jpg (401.33 Kb)
Screenshot_3.jpg (370.61 Kb)
Administrator  Posts: 906
Nov 18, 2023 11:36
Hi Junky! And welcome here! Thanks for bugrep! I have fixed this bug already just few days ago. And I will upload the update once I finish preparing 0.68 release with new features. It's expected within 2 weeks.
junky-junky wrote:
Then I close the IPR window and open it again and this strange pattern covers image. After closing the window, Cinema crashes.
That's the key. The issue is with Nvidia OptiX denoiser that we use. There was no any problem before driver update (I used some 1 year old driver). But the issue appeared with fresh drivers. On the software side it was possible to fix the issue and it no longer appears on the future CentiLeo.

For now you may even turn Denoiser value to zero and the glitch will dissappear.
In my case it was enough to restart Cinema to get back for correct behavior. And also don't open-close the Interactive Preview window, just keep it always opened.

I will upload the fix together with other new features very soon.

Best regards,
CentiLeo Chat:
Hi, Kirgman! Thanks for your fast answer!
Kirgman wrote:
For now you may even turn Denoiser value to zero and the glitch will dissappear.
Turning Denoiser to zero value works perfect. On other hand I just increased iterations. IPR and Production Render works fine again! :)

You really helped me now! Thanks for your work!

Best regards,
Hello again, Kirgman!

I found that this error completely disappears on drivers version 537.34 from September 2023.

But before rolling back to the old version of the driver, I found an error with the Environment Tag. And its symptoms are very similar to the previous one.

When I add Sky with Environment Tag everything is fine, but when I add texture to Environment Tag - Centileo IPR lives only one attempt. Exactly the same as in the case when the Denoiser turned on early. When I open an existing scene with a texture in the Environment Tag, the render fall on the first try. But when I add a very big Sphere with Emission material with the same texture to the scene instead of Sky - everything fine

I added a short screenrec, maybe it will help solve the problem. File ScreenRecorderProject2_5.mp4 by the link
Administrator  Posts: 906
Dec 2, 2023 05:22
Hi and very big thanks for report and a scene file! Is you HDRI texture a HDR or EXR file? Cinema 2023 or 2024?
I have found Cinema 23 and 24 crashes itself when we add a bitmap with EXR. It's not the case with older Cinema. And it's a bug in Cinema code as I currently figured out. But will also look into your scene, thanks for this!
CentiLeo Chat:
Hi, Kirgman! Thanks for answer! This problem appears in 2023 and 2024 versions, but in the 2024 version this bug appears more often. I did some tests, and looks like problem with EXR textures, tag with HDR pass changing texture, reopen IPR, deleting cache file, PV render in 2024 version. *.jpg, *.png, ets. in tag works fine too.

I'm trying S24 version, seems like everythin ok and Enviroment Tag with texture works right. And cache file (*.cntx) created. By the way, if you then open the same scene in 2024, when the cache file was created by version S24, the chance of catching a bug is minimal

But...) When I open this scene in S24 version, the Color Node in material node editor becomes a potato)
Screenshot_1.jpg (30.47 Kb)
Edited: junky-junky - Dec 3, 2023 18:54 (Add image)
Administrator  Posts: 906
Dec 22, 2023 18:27
Btw the issue in the topic start was fixed. But the one with .EXR reader in 2023/2024 Cinema is not because it's Maxon bug :) I will probably use a different library for texture reading or consult with them
CentiLeo Chat:
Pages: 1
Users browsing this topic